jQuery, le bulletin hebdomadaire

jQuery, bulletin n°14

Flattr this!

Je commence par répondre à une question posée en commentaires la semaine dernière par gtraxx, la version 1.9 de jQuery UI approche. Pas de date précise pour le moment, Scott Gonzalez pense que cela se fera dans les prochains mois. Entre 2 et 4 pour être plus précis : http://forum.jquery.com/t[...]69327

Au passage, il est fort possible que l'alpha 4 de jQuery Mobile soit publiée cette semaine. C'est Todd Parker, le concepteur en chef de jQuery UI et jQuery Mobile qui a lâché l'info : http://forum.jquery.com/t[...]63403

Dans les specs de jQuery UI, il y a un petit nouveau qui n'a pas encore éveillé beaucoup de débats mais le sujet ne devrait pas laisser de marbre très longtemps la plupart des contributeurs ne serait-ce que pour les problèmes récurrents de performances. Un module "Image Preloading" permettant un préchargement des images est donc à l'étude : http://wiki.jqueryui.com/[...]ading

D'ailleurs, je vous incite à repasser sur mon blog dans la semaine, je ne parlerai de pré-chargement, pas d'images mais de script. Je me suis frotté à Head.js et je devrais pouvoir vous faire un billet dans quelques jours.

Scott Gonzalez a proposé quelque chose de sympa pour les Tabs de jQuery UI, la possibilité de naviguer au clavier entre les onglets en utilisant les flèches gauche et droite. Pas de specs précises à l'heure actuelle, une suggestion seulement que j'espère voir mise en place pour la 1.9.

Rien d'autre à signaler, la semaine a été assez calme. Bonne semaine à tous!

Flattr this!

A propos de Mathieu

Ingénieur développeur web dans la vente par correspondance B2B, adepte de nouvelles technologies et d'innovation. Vous pouvez aussi me retrouver sur Twitter @mathrobin
Cette entrée a été publiée dans jQuery, avec comme mot(s)-clef(s) , , , , , . Vous pouvez la mettre en favoris avec ce permalien.
  • Syndrael

    Juste une question comme ça.. Tu penses que JQuery 1.5.1. est full-compatible avec jquery-ui-1.8.10 ?

  • http://www.mathieurobin.com Mathieu

    A tester mais je ne pense pas. Ils continuent de distribuer jQuery UI 1.8.10 avec jQuery 1.4, pour moi ça veut dire soit non, soit que les tests de compatibilité ne sont pas tous terminés.
    Mais je n’y crois pas, à mon avis, ça sera pour la 1.9 avec un peu de chance ou la 2.0.

  • http://www.magix-cms.com gtraxx

    Je vous assure que jQuery ui 1.8.10 est compatible avec jQuery 1.5.1 après plusieurs tests et une intégration complète dans magix cms.
    Bref, il reste pas mal de travail sur jQuery UI 1.9 mais c’est compatible mais il faut tester tous les aspect de jQuery Ui pour trouver des incohérences.
    Par contre il y avais quelques soucis avec jQuery 1.5 :)
    Je continue mes investigations sur la conception MVC à grande échelle suivant les frameworks disponible bien entendu avec jQuery.

  • http://www.mathieurobin.com Mathieu

    Bon bah gtraxx a tout dit 😀 Merci à toi!

Articles liés