jQuery, le bulletin hebdomadaire

jQuery, bulletin n°17

Flattr this!

On commence direct avec la nouvelle la plus intéressante :

jQuery 1.5.2 est disponible!

Vous pouvez utiliser le hot linking pour l'inclure dans vos applications via les CDN de Google (lien) ou de Microsoft (lien). Pour ce qui est des changements, rien de différent avec ce que j'avais décrit dans mon bulletin précédent.

Pour info, il y a quelques hésitations à sortir une version 1.5.3 de jQuery. Les prochaines idées qui seront implémentées étant assez intéressantes, l'équipe songe à passer directement à la version 1.6 pour début mai (lien). Visiblement, la manie de Google de sortir plusieurs versions de Chrome dans l'année n'a pas atteint que l'équipe de Firefox. On peut donc s'attendre à une beta mi-avril.

En parlant de Firefox, certains utilisateurs ont rencontré des problèmes avec le Themeroller de jQuery UI sous la version 4 du navigateur. Après tests, je n'ai rien vu mais bon, je suis peut-être passé à côté d'un bug.

Du côté de jQuery Mobile, pour information, un composant Tabs est prévu dans l'année, sans qu'on en sache vraiment plus. Vous pouvez toujours en discuter ici : lien.

Voilà, je crois qu'on a fait le tour. Bonne semaine à tous!

PS: vous avez vu la nouvelle bannière d'en-tête dédiée au bulletin hebdomadaire? Vous en pensez quoi? 😉

Flattr this!

A propos de Mathieu

Ingénieur développeur web dans la vente par correspondance B2B, adepte de nouvelles technologies et d'innovation. Vous pouvez aussi me retrouver sur Twitter @mathrobin
Cette entrée a été publiée dans jQuery, avec comme mot(s)-clef(s) , , , , , , , , . Vous pouvez la mettre en favoris avec ce permalien.
  • http://www.olivierpons.fr/ Olivier Pons

    Ce que je pense de ta bannière ?
    Euh… je pense que tu t’es inspié de celle de http://modx.com. Si ça n’est pas le cas, regarde comme elle est jolie ! Et quand on clique sur les « petits boutons » bah c’est sympa des deux côtés :)

  • http://www.mathieurobin.com/ Mathieu

    Eh non, inspiré par personne, je suis un artiste libre et indépendant!!! —- Hum excusez cet élan de folie, je repose le mégaphone. Plus sérieusement, je sais plus à quoi je pensais quand j’ai fait cette bannière mais effectivement, c’est inspiré. Mais pas par modx.

  • http://www.magix-cms.com gtraxx

    Après test, cette version corrige pas mal de bug que j’ai rencontré.
    J’attends un correctif plus poussé de jQuery UI voir la 1.9 pour ne pas faire chaque fois des upgrades même si je trouve sa amusant.
    L’utilisation des namespaces avec jQuery est un réel plaisir et ce sans trop de contrainte, j’ai remarquer que son utilisation améliore considérablement les performances avec notre cher jQuery ayant problablement une préférence à jouer avec.
    Cela ne regarde que moi, c’est peut être mon FF4 qui tourne mieux de cette manière je n’en sais trop rien.
    Il parait que jQuery 1.5.1 fais planter l’Iphone 3 sauriez-vous confirmer l’information qui me viens d’un utilisateur de mon CMS

  • http://www.mathieurobin.com/ Mathieu

    Pour la possible incompatibilité entre jquery 1.5.1 et l’iPhone 3GS, j’ai posé la question par tweet, on verra bien. Tu sais sur quelle fonctionnalité? Plus de détails?

    J’attends surtout avec impatience la 2.0 de jQuery UI, j’espère un cadre plus « professionnel ». Je suis très attaché au concept de panel (ou équivalent) très présent dans extjs, gwt, swing, wpf … qui n’existe pas dans jQuery. Et j’espère voir ce type de choses dans la 2.0, même si ça ne colle pas avec la philosophie de jQuery.

    • http://www.magix-cms.com gtraxx

      Effectivement le concept de panel est très important, je croise les doigts pour la suite :)
      Pour la possible incompatibilité entre jquery 1.5.1 et l’iPhone 3GS, j’ai posé la question par tweet, on verra bien. Tu sais sur quelle fonctionnalité? Plus de détails?
      Difficile de répondre, j’ai juste un utilisateur de mon cms qui m’explique que sous safari le navigateur se referme directement.on suppose que jQuery est en cause mais sans vraiment savoir a quel niveau.
      La version de IOS sur l’Iphone : c’est la 4.0.1 (8A306) (j’ai pas d’iphone donc je sais pas le vérifier) par contre on a tester avec un autre modèle rapidement et aucun bug.

  • Serge

    J’ai une question dont je ne trouve pas la reponse sur le net.
    J’ai ce message qui apparait : continuer ou arreter le script…
    https://ajax.googleapis.com/ajax/libs/jquery/1.5.2/jquery.min.js
    mon ordi commence a ramer de temps en temps.
    Quel est mon probleme?
    Je n’y connais pas grand chose, j’essaye de comprendre et savoir que faire pour resoudre ce probleme.
    Merci a vous de m’expliquer de quoi il sagit.

    • http://www.mathieurobin.com/ Mathieu

      Certainement un problème de réseau. Vous avez une connexion trop lente et/ou un pc trop lent et ça ne suit plus sur les sites avec des technologies presque modernes. Un conseil ? Changer de pc et de connexion. Mais commencer par faire le ménage sur le pc (antivirus, parefeu, nettoyage etc …) avant de déployer l’artillerie lourde en rachetant tout 😉

Articles liés