Logo_jQuery

Quel niveau de support pour jQuery Mobile 1.1 ?

flattr this!

Suite à la sortie de jQuery Mobile 1.1, refaisons un point sur la compatibilité. Sont indiqués les terminaux testés. On notera, par rapport aux pré-versions de jQuery Mobile 1.0, qu'un effort énorme a été fourni sur la compatibilité.

A - Haute qualité

Le navigateur peut, à minima, gérer des requêtes sur divers types de média, condition sine qua non pour jQuery Mobile. Ces navigateurs sont activement testés mais ne recevront pas forcément toutes les capacités de jQuery Mobile.

  • Android 1.5-1.6 – Google G1, risques de soucis de performance ;
  • Android 2.1-2.3 – HTC Incredible (2.2), Droid (2.2), HTC Aria (2.1) et Google Nexus S (2.3) ;
  • Android 3.1 (Honeycomb)  – Samsung Galaxy Tab 10.1 et Motorola XOOM ;
  • Android 4.0 (ICS) – Galaxy Nexus S. Note : Des ralentissements sur les transitions peuvent apparaître sur les versions mises à jour ;
  • Apple iOS 3.2-5.0 – iPad (4.3 / 5.0), iPad 2 (4.3), iPhone (3.1), iPhone 3 (3.2), 3GS (4.3), 4 (4.3 / 5.0) et 4S (5.0) ;
  • Blackberry 6.0 – Torch 9800 et Style 9670 ;
  • Blackberry 7 – BlackBerry Torch 9810 ;
  • Blackberry Playbook (1.0-2.0) – PlayBook ;
  • Chrome Desktop 11-17 – OS X 10.7 et Windows 7 ;
  • Chrome for Android (Beta) – Android 4.0 ;
  • Firefox Desktop 4-9 – OS X 10.7 et Windows 7 ;
  • Firebox Mobile (10 Beta) – Android 2.3 ;
  • Internet Explorer 7-9 – Windows XP, Vista et 7 ;
  • Kindle 3 and Fire – navigateur WebKit embarqué ;
  • Meego 1.2 – Nokia 950 et N9 ;
  • Nook Color 1.4.1 – Nook Color ;
  • Opera Desktop 10-11 – OS X 10.7 et Windows 7 ;
  • Opera Mobile 11.5 – Android 2.3 ;
  • Palm WebOS (1.4-2.0) – Palm Pixi (1.4), Pre (1.4) et Pre 2 (2.0) ;
  • Palm WebOS 3.0 – HP TouchPad ;
  • Safari Desktop 4-5 – OS X 10.7 et Windows 7 ;
  • Samsung bada 2.0 – Samsung Wave 3 et Dolphin browser ;
  • Skyfire 4.1 – Android 2.3 ;
  • UC Browser – Android 2.3 ;
  • Windows Phone 7-7.5 – HTC Surround (7.0), HTC Trophy (7.5), LG-E900 (7.5) et Nokia Lumia 800.

B - Qualité moyenne

Le navigateur a du potentiel mais n'est pas encore assez présent sur le marché pour être testé tous les jours, cependant, des correctifs seront quand même régulièrement apportés pour les aider.

  • Blackberry 5.0 – Storm 2 9550 et Bold 9770 ;
  • Opera Mini (5.0-6.5) – iOS 3.2/4.3 et Android 2.3 ;
  • Nokia Symbian^3 – Nokia N8 (Symbian^3), C7 (Symbian^3) et N97 (Symbian^1).

C - Faible qualité

Le navigateur ne peut pas gérer les requêtes multimédia. Il ne sera donc pas supporté par jQuery Mobile.

  • Blackberry 4.x – Curve 8330 ;
  • Windows Mobile – HTC Leo (WinMo 5.2) ;
  • Tout autre ancien smartphone et téléphone.

Rien

Le navigateur n'existe pas/ est en alpha/beta et donc, pas de support pour jQuery Mobile. Cette catégorie disparaît du classement, toutes les plateformes possibles et imaginables passant en niveau C.

flattr this!

A propos de Mathieu

Ingénieur développeur web dans la vente par correspondance B2B, adepte de nouvelles technologies et d'innovation. Vous pouvez aussi me retrouver sur Twitter @mathrobin
Cette entrée a été publiée dans jQuery, avec comme mot(s)-clef(s) , , , , . Vous pouvez la mettre en favoris avec ce permalien.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Vous pouvez utiliser ces balises et attributs HTML : <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Articles liés